编译安装更新SSH到6.7

| |
[不指定 2015/10/04 14:25 | by 刘新修 ]
C++代码
  1. 下载openssh-6.7p1.tar.gz  
  2. wget http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-6.7p1.tar.gz  
  3. cd openssh-6.7p1/  
  4.   
  5. 备份ssh配置文件 :  
  6. mv /etc/ssh /etc/ssh.bak  
  7.   
  8. 查看是否缺包  
  9. rpm -qa | egrep "gcc|make|perl|pam|pam-devel|zlib|zlib-devel"  
  10.   
  11. 如果有配置yum了的话可以直接yum安装这些包,这样既可以检验是否装了,没装的直接装上。  
  12. yum -y install gcc* make perl pam pam-devel zlib zlib-devel openssl openssl-devel  
  13.   
  14. 先卸载完旧版本的openssh  
  15. rpm -e `rpm -qa | grep openssh  
  16.   
  17. 如果configure时出现-- configure: error: *** OpenSSL headers missing - please install first or check config.log ***  
  18. [root@localhost openssh-6.7p1]#   
  19. 解决办法:安装openssl以及openssl-devel  
  20. yum install openssl openssl-devel  
  21.   
  22. ./configure --prefix=/usr --sysconfdir=/etc/ssh --with-pam --with-zlib --with-md5-passwords  
  23. make  
  24. make install  
  25.   
  26. 查看最新的版本:  
  27. sshd -v  
  28.   
  29. 复制启动脚本到/etc/init.d  
  30. cp /home/openssh-6.7p1/contrib/redhat/sshd.init /etc/init.d/sshd  
  31.   
  32. 加入开机自启  
  33. chkconfig --add sshd  
  34. chkconfig sshd on  
  35. chkconfig --list  
  36.   
  37. 启动sshd,用start或reload。不要restart,restart 会直接断开连接,而并不会接着启动sshd服务,这时候要通过其他途径进入机器,然后启动sshd服务才行。  
  38.   
  39. 如果xshell4连接不上,修改配置,使xshell4默认支持:  
  40. vi /etc/ssh/sshd_config  
  41. #x11Forwarding yes  
  42. #UseLogin yes  
Linux/Unix | 评论(0) | 引用(0) | 阅读(1809)